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Version 1.2
Before You Begin

Estimated time to complete this lab

45 minutes
Objectives

After completing this lab, you will be able to:

· Browse a Microsoft® SQL Server® 2008 Analysis Services cube by using Microsoft Office Excel® 2007.
· Use Online Analytical Processing (OLAP) formulas in Microsoft Office Excel 2007.
· Display Analysis Services Key Performance Indicators in Microsoft Office SharePoint® Server 2007.
Prerequisites

Before working on this lab, you must have:

· Familiarity with basic Microsoft Excel functionality and terminology.
· Familiarity with SQL Server Analysis Services concepts and terminology.
Lab Setup

Lab scenario
Adventure Works Cycles, a bicycle manufacturing company, uses multidimensional analysis to better understand its customer base. Over time, the company has collected information about past customers and sales. It now wants to use this information to gain insights about its customers. The company also wants to compare actual sales to the sales quotas that have been set for the different regions in which the company sells products.
Virtual PC

This lab makes use of Microsoft Virtual PC 2007, which is an application that allows you to run multiple virtual computers on the same physical hardware. During the lab, you will use a virtual machine running Windows Server® 2003.

Before you start the lab, familiarize yourself with the following basics of Virtual PC:

· To switch the focus for your mouse and keyboard to the virtual machine, click inside the virtual machine window.

· To remove the focus from a virtual machine, move the mouse pointer outside the virtual machine window.

· To mimic the CTRL+ALT+DELETE key combination inside a virtual machine, use RIGHT-ALT+DELETE. In Virtual PC, the RIGHT-ALT key is called the host key.

· To enlarge the size of the virtual machine window, drag the lower-right corner of the window as seen in the screenshot.
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· To switch to and from full-screen mode, press RIGHT-ALT+ENTER.
Computers in this lab

This lab uses one computer as described in the following table. Before you begin the lab, you must start the virtual machines and then log on to the computers. In each exercise, you only have to start the virtual machine that is needed.

	Virtual Machine
	Computer Name
	User Name
	Password

	SQL Server 2008 HOLs
	MIAMI
	Student
	Pa$$w0rd


Start the virtual machine

1. Launch Microsoft Virtual PC from the Start menu or desktop. If the Virtual PC console does not appear, double-click its icon in the notification area.
2. Select SQL Server 2008 HOLs, and then click Start.

3. When the virtual server is running, in the virtual server window, on the Action menu, click Ctrl+Alt+Del (or press RIGHT-ALT+DELETE on your keyboard) to send a CTRL+ALT+DEL sequence to the logon dialog box within the virtual server window.
4. Type the following information, and then click OK:

· User name: Student
· Password: P@ssw0rd
Exercise 1: Working with Analysis Services Data through Microsoft Excel 2007
In this exercise, you will use Microsoft Office Excel 2007 to browse and analyze your data stored in Analysis Services. You will use both Microsoft Office Excel PivotTable® and Microsoft Office Excel PivotChart® to provide both numerical and graphical representations of your data. You will also explore how adding Key Performance Indicators (KPIs) within your PivotTables can help users to better visualize the trends within your data. You will further expand the reach of your reports by adding a drillthrough action to enable key decision-makers to see additional properties associated with your data. Finally, you will use a perspective to better focus users on the data specific to the tasks they are performing.
Note: A sample of a possible solution for Exercise 1 can be found at C:\SQLHOLS\Analysis Services Through MS Office\Solution\AdventurePivot.xls.

Create the Analysis Services database

5. Click Start, and then click Computer.
6. Browse to the C:\SQLHOLS\Analysis Services Through MS Office\Starter folder.

7. Double-click Setup.cmd.

8. Wait for the Command Prompt window to close before proceeding with the lab.

Note: This script deploys an Analysis Services database to the local server.

Create a PivotTable
9. Click Start, point to All Programs, point to Microsoft Office, and then click Microsoft Office Excel 2007.
10. On the Excel ribbon, click the Data tab.
11. On the Data tab, in the Get External Data group, click From Other Sources, and then click From Analysis Services.
12. On the Connect to Database Server page, in the Server name box, type (local) and then click Next.
13. On the Select Database and Table page, in the Select the database that contains the data you want box, select the Adventure Works OLAP database, click Adventure Works Cube, and then click Next.
14. On the Save Data Connection File and Finish page, click Finish.
15. On the Import Data page, review the default settings, and then click OK.
16. Scroll through the PivotTable Field List pane to familiarize yourself with the content and layout of the list. Measure Group folders are at the top of the list and are marked as Values (Σ). KPIs are located in the middle of the list, followed by Dimension folders.
17. Near the top of the PivotTable Field List, in the Show fields related to drop-down list, click Reseller Sales. Scroll through the list and notice that only items that are related to Reseller Sales are listed.
18. In the Show fields related to drop-down list, click (All).
19. In the PivotTable Field List, under Reseller Sales, select the check box for Reseller Sales-Sales Amount. Because Reseller Sales-Sales Amount is a measure value in the cube, it is placed in the Σ Values area. After more than one measure is added, the Σ Values group is listed as Column Labels by default, but the group can also be moved to Row labels by using simple drag-and-drop functionality. Note how the Reseller Sales Amount is automatically formatted in currency. This is because the measures have been preformatted in the Analysis Services cube.
Tip: If you click outside of a PivotTable or PivotChart, the PivotTable Field List and PivotTable Tools ribbon will no longer be visible. To show the PivotTable Field List and PivotTable Tools ribbon, click inside the PivotTable or PivotChart.
20. In the PivotTable Field List, under Sales Quotas, select the check box for Sales Amount Quota.
21. In the PivotTable Field List, under Sales Territory, select the check box for Sales Territories. The Sales Territories are added to the Row Labels area.
22. In the PivotTable Field List, under Ship Date, expand Fiscal, and drag Ship Date.Fiscal Year to the Column Labels area of the Drag fields between areas below pane. Examine the data in Sheet1. Notice that you can now see both measure values for each of the years and also the totals.
23. In the PivotTable Field List, under Ship Date, point to Fiscal Year, and then click the arrow to the right of Fiscal Year to edit the filters.

24. At the bottom of the filter page, clear the check boxes for 2002, 2003, and 2005 (this leaves only 2004 selected), and then click OK. The filters can also be edited by clicking the arrow in cell B1 next to Column Labels.
Browse a PivotTable
25. In the Pivot Table Field List, in the Drag Fields between areas below area, click the drop-down arrow on the Fiscal Year field, and then click Remove Field.

26. In the PivotTable Field List, under Ship Date, expand Calendar, and then select the Ship Date.Calendar Quarter check box. The default view places the Calendar Quarter in the Column Labels area; this provides too much information and makes the report difficult to read. In the next step, you will move the Calendar Quarters to the Report Filter area to enable you to view totals for specific quarters.

27. In the Pivot Table Field List, in the Drag Fields between areas below area, drag Ship Date.Calendar Quarter from the Column Labels box to the Report Filter box.

28. On Sheet1, click the Ship Date.Calendar Quarter All Periods arrow, click Select Multiple Items, expand All Periods, select only the four periods in CY 2002, and then click OK. Notice the change in the values that are reported.

29. On Sheet1, expand Europe, and then expand North America. View the results in the report.

30. On Sheet1, click the Ship Date.Calendar Quarter All Periods filter button, select All Periods, and then click OK. Notice the increase in the values that are reported.

31. In the PivotTable Field List, in the Row Labels box, click the arrow next to the Sales Territories field, and then click Remove Field.

32. In the PivotTable Field List, under Product, select the checkbox for Product Categories.

33. On Sheet1, expand Bikes, expand Mountain Bikes, and point to the cell that contains Mountain-100 Silver-38 until a tooltip listing member properties for that particular mountain bike model is displayed.

34. On Sheet1, point to the cell B12. A tooltip appears with information about the value and the fields that it represents.

35. On Sheet1, in cell A4, click the Row Labels drop-down list.
36. In the Select field drop down box, click Product Name, point to Label Filters, click Equals, set the label filter to Product Name – Color equals Silver, and then click OK. Note how only products with a Color property of Silver now appear in the results.
Create a PivotChart
37. On the Excel ribbon, on the PivotTable Tools tab, on the Options tab, click PivotChart.

38. On the Insert Chart page, verify that the first Column style chart is selected, and then click OK.

39. On the Design Tab of the PivotChart Tools tab, click Move Chart.

40. On the Move Chart page, in the Object in list, select Sheet2, and then click OK.
41. Drag the corners of the chart to resize it to fill the visible area of the spreadsheet, and then move the PivotChart Filter Pane window so you can see the chart clearly.
Browse a PivotChart
42. In the PivotChart, right-click the Mountain Bikes axis label, point to Expand/Collapse, and then click Collapse. The chart collapses to hide the individual mountain bikes.
43. On the PivotChart, right-click the Bikes axis label, point to Expand/Collapse, and then click Collapse Entire Field. The chart collapses to hide all subcategories of bike.
44. In the Pivot Table Field List, click the Ship Date.Calendar Quarter arrow in the Report Filter area, and then click Remove Field. Notice that the values change to the totals for all years.

45. In the Pivot Table Field List, expand Ship Date, expand Calendar, and then drag Calendar Year to the Axis Fields box in the Drag fields between areas below area. Review the results in the chart.
46. In the Drag fields between areas below area, drag the Calendar Year field to the Legend Fields area. Review the results in the chart.
47. Remove the Sales Amount Quota field from the PivotChart.

48. On the Design tab, use the Chart Layouts and Chart Styles groups to select a style and layout appropriate for the data.

Add a KPI to an Excel 2007 PivotTable
49. At the bottom of the sheet, click the Sheet3 tab.
50. On the Excel Ribbon, click the Insert tab.

51. In the Tables group, click the arrow underneath PivotTable, and then click PivotTable.

52. On the Create PivotTable page, select Use an external data source, and then click Choose Connection.

53. On the Existing Connections page, under Connections in this Workbook, click (local) Adventure Works OLAP Adventure Works Cube, and then click Open.

54. On the Create PivotTable page, select Existing Worksheet, verify that the Location box contains the text Sheet3!$A$1, and then click OK.
55. In the PivotTable Field List, under Date, expand Calendar, and then drag Date.Calendar Year to the Row Labels box in the Drag fields between areas below section.

56. In the PivotTable Field List, expand KPIs, expand Actual Sales VS Quotas, and then click Value, Goal, Status, and Trend to add them to the PivotTable.
Note: Adventure Works Cycles has set very high sales quotas. Because of this, the KPI shows a positive status (green light) if the value is greater than or equal to 83 percent of the goal. A neutral status (yellow light) is between 80 and 83 percent. A negative status (red light) is a value below 80 percent of the goal. The trend is defined as positive (up arrow) if there was at least a two percent growth in sales between the two years, neutral (horizontal arrow) if there was no change or an increase of less than two percent, and negative (down arrow) for any other conditions.
Tip: You can view all KPIs created in Analysis Services in Excel. The default icons set is determined by the icon defined in the Analysis Services KPI. You can manage how these icons look through the Icon Sets option within Conditional Formatting on the Styles section of the Home tab in the Excel ribbon.
Use an action in a PivotTable
Note: In Analysis Services, actions can be created to enable users to perform additional tasks based on the outcome of the analyses. Actions are stored commands created on the Analysis Services server. You can access Analysis Services actions from within your PivotTables in Excel 2007. These actions include displaying Reporting Services report, redirecting the user to a specific URL, and others.
57. Press SHIFT+F11 to insert a new worksheet. This worksheet should be named Sheet4. If it has a different name, adjust any of the following directions to reflect the new sheet name.

58. On the Excel Ribbon, click the Insert tab.

59. In the Tables group, click the arrow underneath PivotTable, and then click PivotTable.

60. On the Create PivotTable page, select Use an external data source, and then click Choose Connection.

61. On the Existing Connections page, under Connections in this Workbook, click (local) Adventure Works OLAP Adventure Works Cube, and then click Open.

62. On the Create PivotTable page, select Existing Worksheet, verify that the Location box contains the text Sheet4!$A$1, and then click OK.
63. In the PivotTable Field List, in the Show fields related to drop-down list, click Internet Sales.

64. In the PivotTable Field List, under Internet Sales, expand Sales, and then select the checkbox for Internet Sales – Sales Amount.

65. In the PivotTable Field List, under Product, select the checkbox for Product Categories.

66. In cell B2, right-click the sales amount for accessories, point to Additional Actions, and then click Internet Sales Detail Drillthrough. A new worksheet displays the item description and order number for each order in the Accessories category.
67. Click the Sheet4 tab, right-click cell B2, and then click Show Details. A new worksheet displays the first one thousand rows of the underlying data that the B2 value is based on.
Connect to a perspective
Note: Within Analysis Services, you can define perspectives, which are subsets of the cubes that have been created in an Analysis Services database. Perspectives hide elements of the cube that are not applicable to the current user. This makes complex cubes easier to use for users with specific analytical requirements..
68. Press SHIFT+F11 to insert a new worksheet. This worksheet should be named Sheet7. If it has a different name, adjust any of the following directions to reflect the new sheet name.

69. On the Excel Ribbon, click the Data tab.

70. On the Data tab, in the Get External Data group, click From Other Sources, and then click From Analysis Services.

71. On the Data Connect to Database Server page, in the Server name box, type (local) and then click Next.

72. On the Select Database and Table page, in the Select the database that contains the data you want box, select the Adventure Works OLAP database, in the Name column, click the Internet Marketing perspective, and then click Next.
Note: The Internet Marketing perspective contains only the measures, dimensions, and KPIs that are important to the Internet Marketing group.
73. On the Save Data Connection File and Finish page, click Finish.
74. On the Import Data page, review the default settings, and then click OK.

75. In the PivotTable Field List, scroll through the values and fields that are available.

76. Use the PivotTable Field List to create and browse through a PivotTable based on the Internet Marketing Perspective. If you need assistance, see “Create a PivotTable” earlier in this exercise.

77. When you are finished, click the Office Button, and then click Save.

78. On the Save As page, browse to C:\SQLHOLS\Analysis Services Through MS Office\Starter, type AdventurePivot and then click Save.

79. Keep Excel open for the next exercise.
Exercise 2: Using OLAP Formulae in Excel
In this exercise, you will use OLAP formulae to create a report in Excel. Using Formulae enables you to create highly customizable reports that provide greater control of data placement than PivotTables. You will also explore report capabilities by reordering the report based on sales volume. Finally, you will convert a PivotTable to Formulas. When you convert a PivotTable to formulas, Excel provides you with the ability to define whether you want the report filter fields to remain dynamic or to be converted to formulae.
Create a connection to an Analysis Service cube
80. In Microsoft Office Excel 2007, close any existing workbooks, and then create a new blank workbook.

81. On the Excel ribbon, on the Data tab, in the Get External Data group, click From Other Sources, and then click From Analysis Services.

82. On the Data Connect to Database Server page, in the Server name box, type (local) and then click Next.

83. On the Select Database and Table page, in the Select the database that contains the data you want box, select the Adventure Works OLAP database, in the Name column, click Adventure Works Cube, and then click Next.
84. On the Save Data Connection File and Finish page, change the File Name to Adventure.odc, click Browse, change the path to C:\SQLHOLS\Analysis Services Through MS Office\Starter, and then click Save.

85. On the Save Data Connection File and Finish page, change the description to Office Connection for Adventure Works OLAP, change the Friendly Name to Adventure, and then click Finish.

86. On the Import Data page, select Only Create Connection, and then click OK.

87. Click the Office button, click Save, browse to C:\SQLHOLS\Analysis Services Through MS Office\Starter, in the File name box, type Adventure1 and then click Save.
Create a report by entering formulae into workbook cells
In this procedure, you will use OLAP formulae to create a report that includes the Internet Sales amounts for the 2003 and 2004 fiscal years for all products. To create this report, enter formulae into cells in this workbook as shown in the following steps. Note that you can take advantage of auto-complete at any time by selecting an item from the dropdown list by using the TAB key or by double-clicking. Widen the columns as necessary to see the data returned by the formulae.
88. A cube member is a coordinate along one of the cube’s dimensions. Enter four members from the cube into spreadsheet cells by using the following formulae.
	Cell
	Formula

	C1
	=CUBEMEMBER("Adventure","[Product].[Category].[All Products]")

	C2
	=CUBEMEMBER("Adventure","[Date].[Fiscal Year].[All Periods].[FY 2003]")

	C3
	=CUBEMEMBER("Adventure","[Measures].[Internet Sales-Sales Amount]")

	D2
	=CUBEMEMBER("Adventure","[Date].[Fiscal Year].[All Periods].[FY 2004]")


89. A tuple is a coordinate representing the intersection of one or more cube members. Enter two tuples based on the preceding members by using the following formulae.
	Cell
	Formula

	C5
	=CUBEMEMBER("Adventure",C1:C3,"2003 Sales")

	D5
	=CUBEMEMBER("Adventure",(C1,D2,C3),"2004 Sales")


90. A set consists of multiple members in a cube. Enter a set by using the following formula in cell A5.
=CUBESET("Adventure","[Customer].[Customer Geography].[All Customers].Children","Countries")
91. To extract the first member from the set, enter the following formula in cell A6.
=CUBERANKEDMEMBER("Adventure",$A$5,ROW(A1))

92. A cube value is the value of a measure at the intersection of various members in the cube. Enter a CUBEVALUE function in cell C6 as follows.
=CUBEVALUE("Adventure",$A6,C$5)

93. Select cell A6, click the small black dot in the lower-right corner of the cell, and then drag it down to cell A11 to auto-fill this formula into the cells underneath it.

94. Select cell C6, click the small black dot in the lower-right corner of the cell, and then drag it down to cell C11 to auto-fill this formula into the cells underneath it.

95. Select cells C6 to C11, click the small black dot in the lower-right corner of the cell, and then drag one column to the right to auto-fill this formula into the cells in column D.
96. Review the data returned from the Analysis Services cube by the formulae. Figure 1 shows the completed worksheet. Figure 2 shows the formulas in the completed worksheet.
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Figure 2
Sort the data based on sales volume
The following steps will sort the data based on the sales volume during fiscal year 2004, listing the highest sales amount first.

97. Replace the formula in cell A5 with the following formula (cell D5 contains the tuple representing the intersection of Internet Sales for All Products during Fiscal Year 2004).
=CUBESET("Adventure","[Customer].[Customer Geography].[All Customers].children","Countries",2,D5)

98. Observe that the order of the set changes along with all the data on the sheet. The value 2 in the second-last position of the functions defines the sort order as descending, with the highest sales value listed first.
99. Click the Office button, and then click Save. Leave the file open.
Convert a PivotTable to Formulas

100. Click the Sheet2 tab.

101. On the Excel Ribbon, click the Insert tab.

102. In the Tables group, click the arrow underneath PivotTable, and then click PivotTable.

103. On the Create PivotTable page, select Use an external data source, and then click Choose Connection.

104. On the Exiting Connections page, under Connections in this Workbook, click Adventure, and then click Open.

105. On the Create PivotTable page, select Existing Worksheet, verify that the Location box contains the text Sheet2!$A$1, and then click OK. 
106. In the PivotTable Field List, in the Show fields related to drop-down list, click Internet Sales.

107. In the PivotTable Field List, under Internet Sales, expand Sales, and then select the checkbox for Internet Sales – Sales Amount.
108. In the PivotTable Field List, under Customer, expand Location, and then select the checkbox for Customer Geography.

109. In the PivotTable Field List, under Product, select the checkbox for Product Categories.

110. In the PivotTable Field List, under Date, expand Fiscal, and then select the checkbox for Date.Fiscal Year.

111. In the PivotTable Field List, drag the Product Categories field from the Row Labels area to the Report Filter area.

112. On the Excel ribbon, on the PivotTable Tools tab, on the Options tab, in the Tool group, click OLAP tools, and then click Convert to Formulas.
113. On the Convert to Formulas page, read the message, and then click Convert.
The conversion may take several seconds. When the conversion is complete, the data results should be the same. However, the PivotTable layout and the PivotTable Field List have disappeared.
114. On Sheet2, click the A3 cell and view the formula. Repeat this process for cells A8, B4, F10, and B1. Notice that all of the cells except for B1contain CUBE formulas. If you had selected the Convert Report Filters option on the Convert Formulas page, B1 would have contained a CUBE formula and would no longer be able to be changed dynamically.

115. In cell B1, click the arrow next to All Products, expand All Products, click Accessories, and then click OK. Notice that the cells under FY 2002 and FY 2003 are blank because there were no sales for Accessories in those years.

116. Save the spreadsheet, and then close Excel.
Exercise 3: Adding a KPI to a SharePoint Web Page
In this exercise, you will upload an Office Data Connection file to a SharePoint site to enable connectivity to an Analysis Services cube through a SharePoint page. Office SharePoint Server enables users to display KPIs on a SharePoint page. To accomplish this, you will create a KPI List, add a KPI from the Adventure Works OLAP database to the KPI list, add a Web Part to enable the KPI functionality, and link the KPI List to the Web Part. This will allow users to view status and trend information on the SharePoint web page.
Tip: If a SharePoint error stating that an unexpected error has occurred is displayed, click Back and repeat the previous step. If this happens repeatedly, make sure that you are not running additional applications in either the virtual machine or the host computer.
Upload an Office Data Connection file to a SharePoint site
117. Start Microsoft Internet Explorer®, and then browse to http://miami.

118. On the left side of the page, under View All Site Content, click Reports (or click the Reports tab).
119. On the left side of the page, under Resources, click Data Connections.

120. On the Data Connections page, click the arrow next to New, and then click Office Data Connection File.

121. On the Upload Document: Data Connections page, click Browse.

122. On the Choose file page, browse to C:\SQLHOLS\Analysis Services Through MS Office\Starter, click the Adventure.odc Office Connection file that you created in Exercise 2, and then click Open.
123. On the Upload Document: Data Connections page, click OK.

124. On the Data Connections: Adventure page, read the messages presented, and then click OK.

125. On the Data Connections page, under the Name column, point to Adventure, click the drop-down arrow, and then click Approve/reject.

126. On the Data Connections: Adventure page, in the Approval Status section, select Approved, and then click OK.
Create a KPI List
127. On the left side of the page, under View All Site Content, click Reports.

128. On the Reports page, click the Site Actions drop-down list at the top right of the page, and then click View All Site Content.

129. Under the heading All Site Content, click Create.

130. On the Create page, in the Custom Lists column, click KPI List.

131. In the Name and Description area, type AdventureWorks KPIs in the Name box and Key Performance Indicators for the AdventureWorks Company in the Description box, and then click Create. After a short interval, the newly created AdventureWorks KPIs List page is displayed.
Add a KPI to the KPI List
132. On the AdventureWorks KPIs page, on the toolbar, click the arrow next to New, and then click Indicator using data in SQL Server 2005 Analysis Services. (Although you select an option that states SQL Server 2005, you will connect to a SQL Server 2008 Analysis Services database.)
133. On the AdventureWorks KPIs: New Item page, next to the Data Connection box, click the Browse icon.

134. On the Select a Link page, click the Adventure link that you uploaded earlier, and then click OK.
Note: The KPI list will automatically display all the KPIs that have been defined in the Analysis Services database you are connecting to. In this case, the database contains only one KPI.
135. On the AdventureWorks KPIs: New Item page, in the KPI list, select the Actual Sales VS Quotas KPI; in the Name box, type Actual Sales VS Sales Quotas and then click OK.
136. On the AdventureWorks KPIs list page, view the Actual Sales VS Sales Quota indicator that you just added.
Add a Web Part to a web page for display of the KPI List
137. Click the Site Actions drop-down list, and then click Create Page.
138. On the Create Page page, in the Title box, type Adventure Works KPIs
139. In the Page Layout section, select (Welcome Page) Blank Web Part Page, and then click Create.

140. On the new page, under Header, click Add a Web Part.

141. In the Add Web Parts dialog box, scroll down to the All Web Parts section, under Dashboard, select KPI Details, and then click Add.
You have successfully added a Web Part. A message is displayed in the KPI Details Web Part providing a link called Open the Tool Pane to configure the Web Part.
142. Click Open the tool pane.
143. In the Indicator ToolPane, click the Browse icon next to the KPI List box.

144. On the Select a Link page, under the Look In column on the left side, click Reports.
145. In the center pane, select AdventureWorks KPIs, and then click OK.

146. On the Indicator ToolPane, in the KPI drop-down list, ensure that Actual Sales VS Sales Quotas is selected, and then click OK.
147. Click Publish at the top of the page.
148. View the KPI details page.

149. Close Internet Explorer.
150. Close the virtual machine and discard changes.
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